$re = '/^(Default=Profiles\/)(?:.)+(?\'edition\'default-release|dev-edition-default)$/mi';
$str = '[Install308046B0AF4A39CB]
Default=Profiles/idahodh8.default-release
Locked=1
[InstallCA9422711AE1A81C]
Default=Profiles/tf96jbvc.dev-edition-default
Locked=1
[Profile1]
Name=default-release
IsRelative=1
Path=Profiles/idahodh8.default-release
Default=1
[Profile0]
Name=dev-edition-default
IsRelative=1
Path=Profiles/tf96jbvc.dev-edition-default
[General]
StartWithLastProfile=1
Version=2
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);