#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(Default=Profiles\/)(?:.)+(?'edition'default-release|dev-edition-default)$"
Local $sString = "[Install308046B0AF4A39CB]" & @CRLF & _
"Default=Profiles/idahodh8.default-release" & @CRLF & _
"Locked=1" & @CRLF & _
"" & @CRLF & _
"[InstallCA9422711AE1A81C]" & @CRLF & _
"Default=Profiles/tf96jbvc.dev-edition-default" & @CRLF & _
"Locked=1" & @CRLF & _
"" & @CRLF & _
"[Profile1]" & @CRLF & _
"Name=default-release" & @CRLF & _
"IsRelative=1" & @CRLF & _
"Path=Profiles/idahodh8.default-release" & @CRLF & _
"Default=1" & @CRLF & _
"" & @CRLF & _
"[Profile0]" & @CRLF & _
"Name=dev-edition-default" & @CRLF & _
"IsRelative=1" & @CRLF & _
"Path=Profiles/tf96jbvc.dev-edition-default" & @CRLF & _
"" & @CRLF & _
"[General]" & @CRLF & _
"StartWithLastProfile=1" & @CRLF & _
"Version=2" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")