using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(Default=Profiles\/)(?:.)+(?'edition'default-release|dev-edition-default)$";
string input = @"[Install308046B0AF4A39CB]
Default=Profiles/idahodh8.default-release
Locked=1
[InstallCA9422711AE1A81C]
Default=Profiles/tf96jbvc.dev-edition-default
Locked=1
[Profile1]
Name=default-release
IsRelative=1
Path=Profiles/idahodh8.default-release
Default=1
[Profile0]
Name=dev-edition-default
IsRelative=1
Path=Profiles/tf96jbvc.dev-edition-default
[General]
StartWithLastProfile=1
Version=2
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}