import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(Default=Profiles\\/)(?:.)+(?'edition'default-release|dev-edition-default)$";
final String string = "[Install308046B0AF4A39CB]\n"
+ "Default=Profiles/idahodh8.default-release\n"
+ "Locked=1\n\n"
+ "[InstallCA9422711AE1A81C]\n"
+ "Default=Profiles/tf96jbvc.dev-edition-default\n"
+ "Locked=1\n\n"
+ "[Profile1]\n"
+ "Name=default-release\n"
+ "IsRelative=1\n"
+ "Path=Profiles/idahodh8.default-release\n"
+ "Default=1\n\n"
+ "[Profile0]\n"
+ "Name=dev-edition-default\n"
+ "IsRelative=1\n"
+ "Path=Profiles/tf96jbvc.dev-edition-default\n\n"
+ "[General]\n"
+ "StartWithLastProfile=1\n"
+ "Version=2\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}