import Foundation
let pattern = #"<\/?\w+(\s+\w+=(['"]).*\2)*\s*\/?\s*>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<span>text</span>
<div style=''>text</div>
<div style="color:red;">text</div>
<div style="color:red;" titlt="title aaa">text</div>
<div style="color:red;" >text</div>
<br />
<你好>
<div title='">
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)