$re = '/<\/?\w+(\s+\w+=([\'"]).*\2)*\s*\/?\s*>/m';
$str = '<span>text</span>
<div style=\'\'>text</div>
<div style="color:red;">text</div>
<div style="color:red;" titlt="title aaa">text</div>
<div style="color:red;" >text</div>
<br />
<你好>
<div title=\'">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);