import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\/?\\w+(\\s+\\w+=(['\"]).*\\2)*\\s*\\/?\\s*>";
final String string = "<span>text</span>\n"
+ "<div style=''>text</div>\n"
+ "<div style=\"color:red;\">text</div>\n"
+ "<div style=\"color:red;\" titlt=\"title aaa\">text</div>\n"
+ "<div style=\"color:red;\" >text</div>\n"
+ "<br />\n"
+ "<你好>\n"
+ "<div title='\">";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}