#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<\/?\w+(\s+\w+=(['"]).*\2)*\s*\/?\s*>"
Local $sString = "<span>text</span>" & @CRLF & _
"<div style=''>text</div>" & @CRLF & _
"<div style="color:red;">text</div>" & @CRLF & _
"<div style="color:red;" titlt="title aaa">text</div>" & @CRLF & _
"<div style="color:red;" >text</div>" & @CRLF & _
"<br />" & @CRLF & _
"<你好>" & @CRLF & _
"<div title='">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")