using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\/?\w+(\s+\w+=(['""]).*\2)*\s*\/?\s*>";
string input = @"<span>text</span>
<div style=''>text</div>
<div style=""color:red;"">text</div>
<div style=""color:red;"" titlt=""title aaa"">text</div>
<div style=""color:red;"" >text</div>
<br />
<你好>
<div title='"">";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}