const regex = /<\/?\w+(\s+\w+=(['"]).*\2)*\s*\/?\s*>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\\/?\\w+(\\s+\\w+=([\'"]).*\\2)*\\s*\\\/?\\s*>', 'gm')
const str = `<span>text</span>
<div style=''>text</div>
<div style="color:red;">text</div>
<div style="color:red;" titlt="title aaa">text</div>
<div style="color:red;" >text</div>
<br />
<你好>
<div title='">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}