use strict;
my $str = '<span>text</span>
<div style=\'\'>text</div>
<div style="color:red;">text</div>
<div style="color:red;" titlt="title aaa">text</div>
<div style="color:red;" >text</div>
<br />
<你好>
<div title=\'">';
my $regex = qr/<\/?\w+(\s+\w+=(['"]).*\2)*\s*\/?\s*>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}