re = /<\/?\w+(\s+\w+=(['"]).*\2)*\s*\/?\s*>/m
str = '<span>text</span>
<div style=\'\'>text</div>
<div style="color:red;">text</div>
<div style="color:red;" titlt="title aaa">text</div>
<div style="color:red;" >text</div>
<br />
<你好>
<div title=\'">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end