re = /(localhost|127.0.0.1|192.168.[0-9]{1,3}\.[0-9]{1,3}):?/mi
str = 'localhost
localhost:4444
127.0.0.1
127.0.0.1:1111
192.168.1.1
192.168.1.1:1111'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end