import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(localhost|127.0.0.1|192.168.[0-9]{1,3}\\.[0-9]{1,3}):?";
final String string = "localhost\n"
+ "localhost:4444\n"
+ "127.0.0.1\n"
+ "127.0.0.1:1111\n"
+ "192.168.1.1\n"
+ "192.168.1.1:1111";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}