const regex = /(localhost|127.0.0.1|192.168.[0-9]{1,3}\.[0-9]{1,3}):?/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(localhost|127.0.0.1|192.168.[0-9]{1,3}\\.[0-9]{1,3}):?', 'gmi')
const str = `localhost
localhost:4444
127.0.0.1
127.0.0.1:1111
192.168.1.1
192.168.1.1:1111`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}