package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(localhost|127.0.0.1|192.168.[0-9]{1,3}\.[0-9]{1,3}):?`)
var str = `localhost
localhost:4444
127.0.0.1
127.0.0.1:1111
192.168.1.1
192.168.1.1:1111`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}