#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(localhost|127.0.0.1|192.168.[0-9]{1,3}\.[0-9]{1,3}):?"
Local $sString = "localhost" & @CRLF & _
"localhost:4444" & @CRLF & _
"127.0.0.1" & @CRLF & _
"127.0.0.1:1111" & @CRLF & _
"192.168.1.1" & @CRLF & _
"192.168.1.1:1111"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")