using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(localhost|127.0.0.1|192.168.[0-9]{1,3}\.[0-9]{1,3}):?";
string input = @"localhost
localhost:4444
127.0.0.1
127.0.0.1:1111
192.168.1.1
192.168.1.1:1111";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}