$re = '/(localhost|127.0.0.1|192.168.[0-9]{1,3}\.[0-9]{1,3}):?/mi';
$str = 'localhost
localhost:4444
127.0.0.1
127.0.0.1:1111
192.168.1.1
192.168.1.1:1111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);