use strict;
my $str = 'localhost
localhost:4444
127.0.0.1
127.0.0.1:1111
192.168.1.1
192.168.1.1:1111';
my $regex = qr/(localhost|127.0.0.1|192.168.[0-9]{1,3}\.[0-9]{1,3}):?/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}