import Foundation
let pattern = #"[+]\d{12}|\b(\d{11}|(\d{3}[ ])?\d{4}[- ]?\d{4})\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
97845448
9784-5448
04197845448
+554197845448
041 9784 5448
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)