# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[+]\d{12}|\b(\d{11}|(\d{3}[ ])?\d{4}[- ]?\d{4})\b//g;t' <<< "97845448
9784-5448
04197845448
+554197845448
041 9784 5448"