$re = '/[+]\d{12}|\b(\d{11}|(\d{3}[ ])?\d{4}[- ]?\d{4})\b/';
$str = '97845448
9784-5448
04197845448
+554197845448
041 9784 5448';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;