const regex = /[+]\d{12}|\b(\d{11}|(\d{3}[ ])?\d{4}[- ]?\d{4})\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[+]\\d{12}|\\b(\\d{11}|(\\d{3}[ ])?\\d{4}[- ]?\\d{4})\\b', 'g')
const str = `97845448
9784-5448
04197845448
+554197845448
041 9784 5448`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);