using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[+]\d{12}|\b(\d{11}|(\d{3}[ ])?\d{4}[- ]?\d{4})\b";
string substitution = @"";
string input = @"97845448
9784-5448
04197845448
+554197845448
041 9784 5448";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}