use strict;
my $str = '97845448
9784-5448
04197845448
+554197845448
041 9784 5448';
my $regex = qr/[+]\d{12}|\b(\d{11}|(\d{3}[ ])?\d{4}[- ]?\d{4})\b/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";