#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[+]\d{12}|\b(\d{11}|(\d{3}[ ])?\d{4}[- ]?\d{4})\b"
Local $sString = "97845448" & @CRLF & _
"9784-5448" & @CRLF & _
"04197845448" & @CRLF & _
"+554197845448" & @CRLF & _
"041 9784 5448"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)