import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[+]\\d{12}|\\b(\\d{11}|(\\d{3}[ ])?\\d{4}[- ]?\\d{4})\\b";
final String string = "97845448\n"
+ "9784-5448\n"
+ "04197845448\n"
+ "+554197845448\n"
+ "041 9784 5448";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}