re = /[ \t]*([\w]+)/m
str = ' Purchase,
Dispose,
DepreciatePurchase,
DepreciateRevalue,
DepreciateReversalPurchase,
DepreciateReversalRevalue,
Revalue,
Depreciate,
DisposeOfRevalue,
DisposeOfDepreciation,
DisposeOfRevalueDepreciation,
UndoDispose,
UndoDisposeOfRevalue,
UndoDisposeOfDepreciation,
UndoDisposeOfRevalueDepreciation,
UndoSell'
subst = 'ActionType.$1 => Proto.ActionType.$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result