$re = '/[ \t]*([\w]+)/m';
$str = ' Purchase,
Dispose,
DepreciatePurchase,
DepreciateRevalue,
DepreciateReversalPurchase,
DepreciateReversalRevalue,
Revalue,
Depreciate,
DisposeOfRevalue,
DisposeOfDepreciation,
DisposeOfRevalueDepreciation,
UndoDispose,
UndoDisposeOfRevalue,
UndoDisposeOfDepreciation,
UndoDisposeOfRevalueDepreciation,
UndoSell';
$subst = "ActionType.$1 => Proto.ActionType.$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;