#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[ \t]*([\w]+)"
Local $sString = " Purchase," & @CRLF & _
" Dispose," & @CRLF & _
" DepreciatePurchase," & @CRLF & _
" DepreciateRevalue," & @CRLF & _
" DepreciateReversalPurchase," & @CRLF & _
" DepreciateReversalRevalue," & @CRLF & _
" Revalue," & @CRLF & _
" Depreciate," & @CRLF & _
" DisposeOfRevalue," & @CRLF & _
" DisposeOfDepreciation," & @CRLF & _
" DisposeOfRevalueDepreciation," & @CRLF & _
" UndoDispose," & @CRLF & _
" UndoDisposeOfRevalue," & @CRLF & _
" UndoDisposeOfDepreciation," & @CRLF & _
" UndoDisposeOfRevalueDepreciation," & @CRLF & _
" UndoSell"
Local $sSubst = "ActionType.$1 => Proto.ActionType.$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)