import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[ \\t]*([\\w]+)";
final String string = " Purchase,\n"
+ " Dispose,\n"
+ " DepreciatePurchase,\n"
+ " DepreciateRevalue,\n"
+ " DepreciateReversalPurchase,\n"
+ " DepreciateReversalRevalue,\n"
+ " Revalue,\n"
+ " Depreciate,\n"
+ " DisposeOfRevalue,\n"
+ " DisposeOfDepreciation,\n"
+ " DisposeOfRevalueDepreciation,\n"
+ " UndoDispose,\n"
+ " UndoDisposeOfRevalue,\n"
+ " UndoDisposeOfDepreciation,\n"
+ " UndoDisposeOfRevalueDepreciation,\n"
+ " UndoSell";
final String subst = "ActionType.$1 => Proto.ActionType.$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}