package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[ \t]*([\w]+)`)
var str = ` Purchase,
Dispose,
DepreciatePurchase,
DepreciateRevalue,
DepreciateReversalPurchase,
DepreciateReversalRevalue,
Revalue,
Depreciate,
DisposeOfRevalue,
DisposeOfDepreciation,
DisposeOfRevalueDepreciation,
UndoDispose,
UndoDisposeOfRevalue,
UndoDisposeOfDepreciation,
UndoDisposeOfRevalueDepreciation,
UndoSell`
var substitution = "ActionType.$1 => Proto.ActionType.$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}