use strict;
my $str = ' Purchase,
Dispose,
DepreciatePurchase,
DepreciateRevalue,
DepreciateReversalPurchase,
DepreciateReversalRevalue,
Revalue,
Depreciate,
DisposeOfRevalue,
DisposeOfDepreciation,
DisposeOfRevalueDepreciation,
UndoDispose,
UndoDisposeOfRevalue,
UndoDisposeOfDepreciation,
UndoDisposeOfRevalueDepreciation,
UndoSell';
my $regex = qr/[ \t]*([\w]+)/mp;
my $subst = 'ActionType.$1 => Proto.ActionType.$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";