const regex = /[ \t]*([\w]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[ \\t]*([\\w]+)', 'gm')
const str = ` Purchase,
Dispose,
DepreciatePurchase,
DepreciateRevalue,
DepreciateReversalPurchase,
DepreciateReversalRevalue,
Revalue,
Depreciate,
DisposeOfRevalue,
DisposeOfDepreciation,
DisposeOfRevalueDepreciation,
UndoDispose,
UndoDisposeOfRevalue,
UndoDisposeOfDepreciation,
UndoDisposeOfRevalueDepreciation,
UndoSell`;
const subst = `ActionType.$1 => Proto.ActionType.$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);