# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[ \t]*([\w]+)/ActionType.$1 => Proto.ActionType.$1/gm;t' <<< " Purchase,
Dispose,
DepreciatePurchase,
DepreciateRevalue,
DepreciateReversalPurchase,
DepreciateReversalRevalue,
Revalue,
Depreciate,
DisposeOfRevalue,
DisposeOfDepreciation,
DisposeOfRevalueDepreciation,
UndoDispose,
UndoDisposeOfRevalue,
UndoDisposeOfDepreciation,
UndoDisposeOfRevalueDepreciation,
UndoSell"