// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"encoding=(\"\S+")"#).unwrap();
let string = "<?xml version=\"1.0\" encoding=\"ISO-8859-5\" standalone=\"no\"?>
<ProcessBudgetInformation releaseID=\"9.0\" systemEnvironmentCode=\"Test\" versionID=\"115.0\">
<ApplicationArea>
<Sender>
<Logi";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}