use strict;
my $str = '<?xml version="1.0" encoding="ISO-8859-5" standalone="no"?>
<ProcessBudgetInformation releaseID="9.0" systemEnvironmentCode="Test" versionID="115.0">
<ApplicationArea>
<Sender>
<Logi';
my $regex = qr/encoding=(\"\S+")/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}