$re = '/encoding=(\"\S+")/';
$str = '<?xml version="1.0" encoding="ISO-8859-5" standalone="no"?>
<ProcessBudgetInformation releaseID="9.0" systemEnvironmentCode="Test" versionID="115.0">
<ApplicationArea>
<Sender>
<Logi';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);