import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "encoding=(\\\"\\S+\")";
final String string = "<?xml version=\"1.0\" encoding=\"ISO-8859-5\" standalone=\"no\"?>\n"
+ "<ProcessBudgetInformation releaseID=\"9.0\" systemEnvironmentCode=\"Test\" versionID=\"115.0\">\n"
+ " <ApplicationArea>\n"
+ " <Sender>\n"
+ " <Logi";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}