re = /encoding=(\"\S+")/
str = '<?xml version="1.0" encoding="ISO-8859-5" standalone="no"?>
<ProcessBudgetInformation releaseID="9.0" systemEnvironmentCode="Test" versionID="115.0">
<ApplicationArea>
<Sender>
<Logi'
# Print the match result
str.match(re) do |match|
puts match.to_s
end