# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"encoding=(\"\S+\")"
test_str = ("<?xml version=\"1.0\" encoding=\"ISO-8859-5\" standalone=\"no\"?>\n"
"<ProcessBudgetInformation releaseID=\"9.0\" systemEnvironmentCode=\"Test\" versionID=\"115.0\">\n"
" <ApplicationArea>\n"
" <Sender>\n"
" <Logi")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.