package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`encoding=(\"\S+")`)
var str = `<?xml version="1.0" encoding="ISO-8859-5" standalone="no"?>
<ProcessBudgetInformation releaseID="9.0" systemEnvironmentCode="Test" versionID="115.0">
<ApplicationArea>
<Sender>
<Logi`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}