import Foundation
let pattern = #"(.*)([( ])(.*)\)*(\.decode\((.*["'].*?["'].*)\))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
valami.decode("utf-8", "replace")
str(temp[0].decode('utf-8'))
asd(str(temp[0].decode('Windows-1250'))) qwe
s += str(args[i]).decode('windows-1250', 'replace')
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2decode_p2( $3 ,$5 )"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)