re = /(.*)([( ])(.*)\)*(\.decode\((.*["'].*?["'].*)\))/m
str = ' valami.decode("utf-8", "replace")
str(temp[0].decode(\'utf-8\'))
asd(str(temp[0].decode(\'Windows-1250\'))) qwe
s += str(args[i]).decode(\'windows-1250\', \'replace\')'
subst = '$1$2decode_p2( $3 ,$5 )'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result