#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*)([( ])(.*)\)*(\.decode\((.*["'].*?["'].*)\))"
Local $sString = " valami.decode("utf-8", "replace")" & @CRLF & _
"str(temp[0].decode('utf-8'))" & @CRLF & _
"asd(str(temp[0].decode('Windows-1250'))) qwe" & @CRLF & _
"s += str(args[i]).decode('windows-1250', 'replace')"
Local $sSubst = "$1$2decode_p2( $3 ,$5 )"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)