// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(.*)([( ])(.*)\)*(\.decode\((.*["'].*?["'].*)\))"#).unwrap();
let string = " valami.decode(\"utf-8\", \"replace\")
str(temp[0].decode('utf-8'))
asd(str(temp[0].decode('Windows-1250'))) qwe
s += str(args[i]).decode('windows-1250', 'replace')";
let substitution = "$1$2decode_p2( $3 ,$5 )";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}