import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)([( ])(.*)\\)*(\\.decode\\((.*[\"'].*?[\"'].*)\\))";
final String string = " valami.decode(\"utf-8\", \"replace\")\n"
+ "str(temp[0].decode('utf-8'))\n"
+ "asd(str(temp[0].decode('Windows-1250'))) qwe\n"
+ "s += str(args[i]).decode('windows-1250', 'replace')";
final String subst = "$1$2decode_p2( $3 ,$5 )";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}