const regex = /(.*)([( ])(.*)\)*(\.decode\((.*["'].*?["'].*)\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)([( ])(.*)\\)*(\\.decode\\((.*["\'].*?["\'].*)\\))', 'gm')
const str = ` valami.decode("utf-8", "replace")
str(temp[0].decode('utf-8'))
asd(str(temp[0].decode('Windows-1250'))) qwe
s += str(args[i]).decode('windows-1250', 'replace')`;
const subst = `$1$2decode_p2( $3 ,$5 )`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);