use strict;
my $str = ' valami.decode("utf-8", "replace")
str(temp[0].decode(\'utf-8\'))
asd(str(temp[0].decode(\'Windows-1250\'))) qwe
s += str(args[i]).decode(\'windows-1250\', \'replace\')';
my $regex = qr/(.*)([( ])(.*)\)*(\.decode\((.*["'].*?["'].*)\))/mp;
my $subst = '$1$2decode_p2( $3 ,$5 )';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";